
Processing PhaseSpace Data with 
MotionBuilder 

 
 
 
The purpose of this document is to provide an overview of how to process 
PhaseSpace optical motion data using MotionBuilder. More detailed information 
regarding MotionBuilder features and functionality can be found in the 
MotionBuilder documentation. For information on the PhaseSpace Impulse 
System and associated software refer to the PhaseSpace Impulse User’s 
Manual. 
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1: System and Software Setup 
 

In order to stream data from the PhaseSpace Impulse system (live or simulated 
live) to MotionBuilder, the PhaseSpace plugin for MotionBuilder must be 
installed. The installation steps are: 

 
1. Place the file titled OWL_MBXX.dll in the MotionBuilder plugin directory 

(\bin\plugins) 
 
2. Place the file titled libowlsock.dll in the system32 directory or an 

accessible path (it is best to place this in the system32 directory or some 
other common directory, as this file is also needed by the PhaseSpace 
Windows clients). 

 
3. Confirm that the machine on which the MotionBuilder software is 

installed has a network connection to a PhaseSpace server computer. 
 

If not streaming data, but instead opening a saved .fbx motion file (or importing 
a motion file), skip Section II below and start with Section 3. 
 

 

2: Using the OWL MotionBuilder Plugin 
 

2.1 PhaseSpace Data Processing with MotionBuilder as 
a Slave Client 

 
If using MotionBuilder as a slave client, it is necessary for a primary client to 
open a socket and configure the communications channels to pass data 
from the PhaseSpace Impulse system. The primary client that is normally 
used for this purpose is PhaseSpace Motion Master. However, other 
primary clients may also serve this purpose, such as MotionBuilder 
configured as a primary client (refer to section 2.2). One key point to keep 
in mind is that there can only be one primary client. 
 
The main advantage of using Motion Master as the primary client is that it 
allows for the saving of data in the PhaseSpace rpd format. Having data in 
this format allows for the streaming of the data into MotionBuilder at any 
time, plus it can be streamed using different configuration settings. For 
example, one may record a live session with post processing turned off 
using Motion Master (to optimize CPU usage) and at the same time getting 
additional visual feedback from MotionBuilder in slave mode. The resulting 
rpd file can then be replayed “offline” with post processing turned on in 



Motion Master. This post processed stream can then be recorded in 
MotionBuilder.  
 
The steps needed to use MotionBuilder as a slave client are listed below. 
 

1. Make sure that the PhaseSpace server is on. 
 

2. Run PhaseSpace Motion Master* on the server computer or any 
other networked machine (Windows or Linux). 

 
a) If running Motion Master on the server computer, run master 

in the phasespace directory. 
 

<prompt>master 
 

b) If running Motion Master on a Windows machine, run master 
from any directory. 

 

 
Figure 3.1: PhaseSpace Motion Master 

 
3. In the configuration section of Motion Master, enter the IP address of 

the server computer.  
 
                                                           
* Refer to the PhaseSpace document titled PhaseSpace Impulse: Software manual for more 
information regarding the use of Motion Master 



4. Under the “Mode” dropdown choose the desired mode. The default 
value is Mode 1. 

 
5. Select the number of markers using the “Markers” numeric control. If 

the default LED strings file is being used then multiply the number of 
LED strings being tracked by 8. The result will be the number of 
markers that should be selected. If the LED strings file has been 
customized (refer to the PhaseSpace Impulse: LED System 
document) then the value to select is the actual number of LEDs. 

 
6. (Recommended) Click on the “Postprocess” button to activate real-

time post processing. 
 

7. (Recommended) Enter a value (number of frames) in the 
“Interpolate” edit box. Using a value of at least 4 is recommended. 
IMPORTANT NOTE: Only use multiples of 4. 

 
8. If streaming from a saved PhaseSpace motion capture, load the 

capture file using “Load file…” or “Load Directory…” under the file 
menu of Motion Master and select the file or session using the file 
browser that appears. 

 
9. If streaming from a saved PhaseSpace motion capture, select “Slave 

Activates Stream” from the Stream menu of Motion Master. This is 
necessary so that the once the stream is activated in MotionBuilder, 
it starts from the beginning. 

 
10. If streaming a live capture, click on the “Connect” button in the 

session control bar of Motion Master. If streaming from a saved 
PhaseSpace motion capture, click the play button in the session 
control bar. 

 
11. On the Windows machine run MotionBuilder, under Asset Browser-

>Templates choose Devices and drag the OWL icon to the Viewer 
window. The OWL interface will appear in the Navigator area. 

 
 

 
 



 
 

12. Enter the IP address of the server computer in the Network Address 
edit box.  

 
13. If streaming over a slower network, it may be necessary to change 

the streaming frequency to a lower value using the “Streaming 
Frequency Dropdown”. 

 
14. Click on “Generate a new optical model” to display data. To record, 

in the OWL interface check “Recording”, and on the play control bar 
click on record and play, choose overwrite if popup displays, after 
end of motion click on stop in play control bar. 

 
15. To save the recording to a .fbx file uncheck “Live” in the OWL 

interface and then under File menu item choose “Save As…”. 



Choose .fbx as file type and enter a file name. To save to other 
formats such as .c3d, use the “Export…” choice under the File menu 
item. 

 
 

 

2.2 PhaseSpace Data Processing with MotionBuilder as 
the Primary Client 

 
The OWL MBPro plugin comes with the option of running MotionBuilder as 
a primary client. This would be the preferable mode for a user that is not 
interested in saving data in the PhaseSpace rpd format and is instead only 
interested in saving fbx data. However, as pointed out in section 2.1, there 
are some advantages to saving data in the PhaseSpace format. 
 
Running MotionBuilder as a primary client eliminates Motion Master from 
the PhaseSpace data processing workflow. Having the PhaseSpace 
server machine on and MotionBuilder running on a network connected 
computer is all that is needed. The steps needed to use MotionBuilder as 
a primary client are listed below. 
 

1. Make sure that the PhaseSpace server is on. 
 

2. On the Windows machine run MotionBuilder, under Asset Browser-
>Templates choose Devices and drag the OWL icon to the Viewer 
window. The OWL interface will appear in the Navigator area. 

 
3. Enter the IP address of the server computer in the Network 

Address edit box. 
 

 
4. Check the “Primary Client” checkbox in the OWL interface. 
 



5. Enter the number of markers in the “Markers” edit box in the OWL 
interface. If the default LED strings file is being used then multiply 
the number of LED strings being tracked by 8. The result will be the 
number of markers that should be entered. If the LED strings file 
has been customized then the value to enter is the actual number 
of LEDs. 

 
6. If streaming over a slower network, it may be necessary to change 

the streaming frequency to a lower value using the “Streaming 
Frequency Dropdown” in the OWL interface. 

 
7. Enter the number of frames to interpolate in the “Interpolate” edit 

box of the OWL interface. A minimum value of 4 is recommended. 
 

8. Click on “Generate a new optical model” start the stream. To 
record, in the OWL interface check “Recording”, and on the play 
control bar click on record and play, choose overwrite if popup 
displays, after end of motion click on stop in play control bar. 

 
To save the recording to a .fbx file uncheck “Live” in the OWL interface and then 
under File menu item choose “Save As…”. Choose .fbx as file type and enter a 
file name. To save to other formats such as .c3d, use the “Export…” choice 
under the File menu item. 
 
 
 

3: Connecting PhaseSpace Data to a Model 
(Actor) 
 
The PhaseSpace data must contain full body data with at least a T-pose. 
Open a saved motion capture file in MotionBuilder and select a part of the data 
where the subject is in a T-pose and perform the following steps to connect the 
data to a model. The steps outlined below are described in greater detail in the 
MotionBuilder document titled “Mapping Optical Motion Data”. 

 
1. To simplify this task, it is best to select the Optical Root in the Viewer 

window and use Rotate (keyboard R) and Translation (keyboard T) to 
make sure the T-pose is pointing in the positive Z direction and centered 
(It is a good practice to have the performer stand in the correct position 
and orientation during the T-pose in order to skip this step). 

 



 
Data is centered and facing the positive Z direction 

 
2. In the Asset Browser choose Templates->Characters->Actor and drag to 

the Viewer window. An actor model will appear in the viewer window. 
 



 
 

3. In the Viewer window click on the Display menu and choose X-ray so that 
all the markers are visible. 

 



 
Model (Actor) is in the scene. Select X-Ray under the Display menu to display all 

markers. 
 

4. In the Actor Controls window click on the Show menu and unselect the 
Actor Skeleton item. 

 

 



 
5. The model can now be scaled and positioned to best fit the markers. 

 
a. To scale the entire model: 
 

i. Choose Models Only under the Display menu of the Viewer 
window 

 
ii. Using the spacebar and left mouse button, drag the mouse to 

select the entire model 
 

 
Entire model selected 

 
iii. Return to the Display menu and choose X-Ray again 

 

 
Entire model selected with markers displayed 

 
iv. Use the S key to activate scaling.  The model is then scaled by 

using the left mouse button and dragging on either the red, green, 
or blue cubes that appears in the scene. If necessary, the T key 
can be used to activate translation and the R key can be used to 
activate rotation. Use the O key to turn all of these off. 

 
v. Once scaling is complete, double click in the viewer to unselect 

the model 



 
 

b. To translate and rotate arms and legs to align with the markers use the 
figure in the Actor Controls window and activate rotation (the R key) or 
translation (the T key) in the Viewer window. 

 
i. To translate the model, choose the hips in the Actor Control 

window by clicking on the circle located on the hips of the figure 
and activate translation in the Viewer window (using the T key). 
Translate the model by using the left mouse button and dragging 
on the red, green, or blue arrows that appear in the scene. Use 
the O key to turn off translation. 

 

 
Hips selected in Actor Control window and translation activated in Viewer window 
 

ii. To rotate the arms select one of the shoulders in the Actor Control 
window by clicking on a circle on the shoulder of the figure, and 
then activate rotation (R key) in the Viewer window. Rotate the 
arm by carefully using the mouse to drag on one of the circles that 
appears in the scene. (Use Edit->Undo if a mistake is made). Use 
the O key to turn off rotation. 

 



 
Left shoulder selected in Actor Control Window and rotation activated in Viewer 

window 
 

iii. To rotate the legs select the Left or Right Hip in the Actor Control 
window by clicking on a circle on the upper leg of the figure, and 
then activate rotation (R key) in the Viewer window. Rotate the leg 
by carefully using the mouse to drag on one of the circles that 
appears in the scene. (Use Edit->Undo if a mistake is made). Use 
the O key to turn off rotation. 

 

 
Left Hip selected in Actor Control window and rotation activated in the Viewer 

window 
 

6. Once the model has been scaled and positioned to fit the markers, the 
marker set can be created. In the Navigator window under the Actor 
Settings tab, click on the “Marker Set…” button and choose “Create”. 
Circles will appear on the figure in the window. 

 



 
Creating a marker set 

 

 
Marker set is ready to be created 

 
7. Using the left mouse button, select a marker or set of markers in the 

viewer window. 
 

8. Hold down the Alt key and use the mouse to drag the marker(s) from the 
Viewer window to the appropriate circle on the figure under Actor Settings.  

 
9. Repeat steps 7 and 8 until all the markers that you would like mapped to 

the model have been included in the marker set. In step 7, one should be 
careful to deselect the previously selected markers before selecting a new 
set of markers.  

 
Note: It is important that at least three markers are mapped to the lower torso of 
the model. If there are only two markers for the lower torso, then these two need 
to be defined as a rigid body (refer to “Defining rigid body” section). The rigid 
body center as well as the two markers then should be mapped to the model and 
the center of the rigid body needs to be oriented by clicking on the “oriented” 
check box. 

 



 
Mapping markers to model 

 
10. Click on the “Snap” above the figure in the Actor Settings window. The 

Active check box should be automatically checked and the “Mapping” 
check box in the Actor Controls window should be checked. 

 
11. Click on the play button in the Transport Controls to play the motion. The 

model should follow the motion defined by the markers. 
 

12. To save the motion and marker set choose “Save…” or “Save As…” from 
the File menu. In the Save Options dialog box leave the default settings 
(the export column under the Takes tab should be selected) and then click 
on the Save button at the bottom of the dialog. 

 
 
 

4: Connecting PhaseSpace Data to a 
Character 
 
To connect data to a “Character” in MotionBuilder, one must start with data that 
is already mapped to a model (actor). Thus, one can either continue from section 
II above, or open a file (.fbx) with data connected to a model. 
 
 

1. Using the Asset Browser select the location containing defined characters 
 



2. Use the mouse to drag the selected character to the Viewer window. Use 
the right mouse button to select “FBX Import -> Options…” 

 

 
 

3. In the resulting Open Option popup uncheck any takes that are selected in 
the import column and then click on the “Append” button at the bottom 

 

 
Open options dialog with append button at the bottom 

 



 
Character appended to model 

 
4. A character branch will appear in the Navigator window. Double click on 

the character name and under the Character Settings tab select “Actor 
Input” in Input Type dropdown and select “Actor” in the Input Source 
dropdown. Then make sure to check the Active checkbox. 

 

 
Character settings 

 
5. If in step 3 you neglected to uncheck the takes check box, it will be 

necessary to modify the end frame number in the Transport Controls. To 
play all the data, this number should be set to a value that is equal to or 
greater than the maximum number of frames in the data. Simply double 
click in the end frame edit box and enter the new value. 

 



 
 

6. In order to disable the visibility of the model, deselect “Actor All” in the 
Character Controls window under the “Show…” menu. 

 

 
Deselecting Actor (All) 

 
7. The motion data mapped to the character can now be played using the 

Transport Controls. 
 
 
 
 

5: Rigid Bodies 
 
By creating rigid bodies, one can define relationships between markers that are 
based on fixed distances and angles. Starting with motion data the following 
steps are needed to define rigid bodies in MotionBuilder: 
 



 
 

1. In the navigator window open the “Opticals” branch and double click on 
the “OWL:optical” branch 

 
2. On the right side of the navigator window will be three tabs: Label, Rigid 

Bodies, and Settings. Choose the Rigid Bodies tab by clicking on it 
 

3. In the Viewer window, use the spacebar and left mouse button to select at 
least two markers that form the rigid body (the selected markers will turn 
green) 

 
4. Click on the “Add” button in the Rigid Bodies section of the Navigator 

window (or use the “b” keyboard key). A rigid body will be created and 
added in the rigid body list 

 
5. Unselect the selected markers by double clicking in the background of the 

Viewer window before defining the next rigid body 
 
6. Continue defining rigid bodies until finished 

 



 
Rigid bodies defined in Viewer window (red indicates centers of rigids); Listing of rigid bodies 

 
To export the defined rigid bodies for use on other data sets with the same 
marker configuration: 
 

1. Click on the “Settings” tab which is next to the Rigid Bodies tab 
 
2. Click on the “Export” button at the bottom right 

 
3. Enter a name for the rigid bodies export file 

 
An exported rigid bodies setup can be imported for use with motion data with the 
same marker configuration, thereby saving the time needed to define the rigid 
bodies for each set of data. The import of a rigid bodies setup can be done in 
real-time while data is being streamed or on saved data using the following 
steps: 
 

1. In the navigator window open the “Opticals” branch and double click on 
the “OWL:optical” branch 

 
2. On the right side of the navigator window will be three tabs: Label, Rigid 

Bodies, and Settings. Choose the Settings tab by clicking on it 
 

3. Click on the “Import” button at the bottom and select the rigid bodies setup 
file (.rbs) to be imported. The rigid bodies will be imported and shown in 
the Viewer window 
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